Motor control system failure p1177&p1178 "ar 147 1.6ts lpg" - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 17-06-14 Thread Starter
Status: -
Join Date: May 2014
County: -
Posts: 1
Idea Motor control system failure p1177&p1178 "ar 147 1.6ts lpg"

Hello, this is my forst post on this forum since i started reading a lot usefull info on it. I just bought an 147 1.6ts and it is my first alfa in my experiance of driving. She had on time service all the time and only 145k km. When i take her from dealer the motor contol system check was on and the owner told me it is probably becouse it has been driven on a rserve and that i had to fill her up and drive her for a while and that the check ll be gone. I had been driving the car 3 weeks 500km and the check is still on. I reset the ECU and read the faults p1177&p1178 the guy that readed the codes told me that he had no idea what is the problem and if i get the same check i ll have to come back and see what is going on. Since i cleared the faults i put on an a-tested LPG system and i had been riding for 50-60 kilometers and beep the same check. I went back and they cleared the codes. The other day i wanted to go dfor a ride and when i try to start the car it started wery bad like it had been firing only on 2 -3 cylinders the she stailed. I try to start it agin then she starts but agin missfire. When i try to give a little rew i could hear a boging noise and little bangs from the air filter. Then after 50 km the light comes back and the car starts better in the morning. If i clean the faults it starts bad, when the check comes back she starts better. I can notice poor fuel economy and bad acceleration with check light on. She idles well and revs to 7k without problem. Only the first start is bad and she missfires. Please help im new in this alfa world!
galemk is offline  
Sponsored Links
Status: -
AO Silver Member
scottyf's Avatar
Join Date: Jun 2012
Location: United Kingdom
County: West Midlands
Posts: 5,173
Images: 26

Member car:

Alfa 166

One of three things

MAF Needs changing
Temp Sensor needs changing
Lamda's need changing
scottyf is offline  
Status: -
Join Date: Aug 2014
Location: United Kingdom
County: Staffordshire
Posts: 1

Member car:

Alfa Romeo 147

System failure light.

Hi I have an 02 Alfa 147 Sel-speed 2 litre

A few days ago i drove to my local shop fine. when I came out the car wouldn't start, I tried a few times and it was turning over but not quite firing up. About 20 minutes later is started fine but with the engine light on.

I drove it home and left it for half an hour and it started fine with no light on, I have used it once in the morning and once at night since this and it has started 1st time every time.

I was wondering if there is a chance it was a glitch and it might be ok now?

Any ideas would really help?

Thank you

I love my Alfa.

Last edited by Jodiej2014; 08-08-14 at 13:29. Reason: missed something out
Jodiej2014 is offline  
Status: -
Join Date: Apr 2014
Location: Romania
County: Iasi
Posts: 3

Member car:

156 1.8 TS 2001

I have LPG on my 156 1.8 and the error P1177 pops every now and then but always when using LPG(or switching to LPG).
I can say most of the times I was running low on LPG when it popped up. Sometimes it will light up the MCSF while the engine was being switched from petrol to LPG(never the other way around). I've read some posts that cleaning/replacing the MAF won't fix it because the problem isn't there to begin with.
You should try getting a LPG and ODB interface and connect them both at the same time. Clear all errors from both ECU's and go for a spin. On the LPG software you should display the pressure parameter. On the engine software you should look at RPM, Airflow etc. Install a screen recorder to capture the event. When you first see the MCSF light on just remember the time display on laptop. Go home and check the screen recording and check the LPG pressure and relations on airflow / rpm / lpg pressure at the time of the event and before/after. My bet is there will be a significant drop in LPG pressure and engine will react as he needs more fuel but there is no more left(tank empty).

buy interface cable and get FiatEcuScan to read errors(even if the light went back off the error is still saved); based on them you can find your answer.
hackandmore is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

ar 6ts lpg , control , failure , motor , p1177andp1178 , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome