Possible oil leak and vibration when starting - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Mark Alfa
Status: - Update
Posts: n/a
Help Possible oil leak and vibration when starting

First of all: Possible oil leak

After having the car up in the air I noticed oil on the bottom of the air con pump on the left hand side. I had the same problem last year back in April which I thought could be a head gasket promblem so took it to my Alfa dealer which they removed the timing belt cover and checked for leaks but could not find anything They told me that I may have spilt some oil when topping her up but I cant see how as I use a jug to fill it up and I'm always so careful when I do. It went for a service in July and I've only topped up the oil up twice between then and Christmas. Has anybody else had the same problem?

Secondly: Vibration on start up

The heat shield on the cat section which comes straight off the manifold has a huge crack in it and a few little ones. I only notice the noise when on start up and when steering sharp in reverse. Could the heat shield be the culprit

Thanks Mark
Sponsored Links
Status: -
AO Member
robf781's Avatar
Join Date: Oct 2006
Location: Leeds
Posts: 820

Member car:

Alfa Spider

Re: Possible oil leak and vibration when starting

I think cracked/damaged/loose heat shields are a fairly common problem, you could always try removing it one day before starting the car and then see if the noise goes away. I'm not sure how safe it would be to leave it off permenently, as I'm not sure exactly what it protects from heat.
robf781 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

leak , oil , starting , vibration

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome