147 Radio Display - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 04-01-07 Thread Starter
Status: -
AO Member
Join Date: Mar 2006
Location: Darlington, Co. Durham
Posts: 32

Member car:

147 TS Lusso

147 Radio Display

I'm sure its not repairable, but thought I'd run it passed you guys just incase...

The radio display on my 147 factory fitted radio is on the blink.

The bottom half of the display rarely lights up. If it was permanently off I'd think it was totally gone, but the way it is intermittent makes me think there might just be something loose somewhere?

The display on the instrument panel shows the full name of the radio station being listened to, its just the display on the physical radio cassette that only shows half of the letters.

Any help / advice appreciated

greekpete is offline  
Sponsored Links
Status: -
AO Member
Join Date: Sep 2006
Location: 22 miles from Calais
Posts: 283

Member car:

Series III

Re: 147 Radio Display

Sounds like a loose bulb, as the display is back-lit.
ARAF is offline  
Status: -
AO Member
autocad's Avatar
Join Date: Dec 2005
Location: United Kingdom
County: Warwickshire
Posts: 306
Images: 9

Member car:

to many

Re: 147 Radio Display

try arden audio in alcester they may be able to repair it.

all there details are on ebay.
autocad is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , display , radio

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome