AirCon working funny - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 03-06-14 Thread Starter
Status: -
DimTitos's Avatar
Join Date: May 2010
Location: Greece
County: Attica
Posts: 9
AirCon working funny


Yesterday the aircon on my alfa 156 jtd decided partially to stop working.
I cheked to see if it needs a regas and but the system is full.
At idle it works just fine but as soon as i on the gas pedal it desengages and when I get off the gas and it goes back to idle the clutch of the compressor clunks and it's working again... >.< any ideas what i should start taking apart?
DimTitos is offline  
Sponsored Links
Status: -
AO Silver Member
Alfafamily's Avatar
Join Date: May 2010
Location: United Kingdom
County: Warwickshire
Posts: 5,758
Images: 10
You can't tell how much gas is in it unless it is connected to a machine. It could be on the verge of packing up altogether due to low gas. Or, it could be an electrical issue which would show up on a MES scan. Either way you need to connect to one or both. You shouldn't take it apart until the gas is recovered by the way.
Alfafamily is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

aircon , funny , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome