156 trip computer - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 20-05-14 Thread Starter
Status: -
AO Member
Join Date: Apr 2014
Location: United Kingdom
County: Anglesey
Posts: 16

Member car:

156 1.9jtd

156 trip computer

Hi I have recently bought a 156 1.9jdt the trip computer is not working at all the car has had the original radio replaced with a Sony and the buttons on the steering wheel don't work I was just wondering if that is why the trip computer is not working if they were connected in some way?

Any advice would be much appreciated
Iwanyoung123 is offline  
Sponsored Links
Status: got a new busso s.w.
AO Silver Member
gibot123's Avatar
Join Date: Aug 2013
Location: United Kingdom
County: East Sussex
Posts: 1,670
Does the car register mileage as in the total the car has done in its life or is it just the trip ?
As for the radio it is possible that the harness between the wheel and the radio is not there or it's not comparable. If it is you can get the cable/harness off eBay
It is possible some has disturbed the dash wiring when changing the radio unit.
gibot123 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , computer , trip

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome