Dual zone climate control problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-05-14 Thread Starter
Status: -
AO Member
EddieGT's Avatar
Join Date: Mar 2012
Location: Cyprus
County: Larnaca
Posts: 16
Dual zone climate control problem

Hi guys,

I am experiencing a problem with the dual zone climate control on my GT.
The air coming out of the driver's side vent has higher temperature form the co-drivers side vent and this happens even when the climate control is in auto mode with the temperature of driver side and co-driver side set the same.
I used the multiecuscan software to check it out and I got Right mixing actuator error.
Also the values of treated temperature and actuator position for the right side are very strange. (see attachment)

Has anyone had any similar problems? Any suggestions?

Attached Images
File Type: jpg delphi1.jpg (135.9 KB, 18 views)
EddieGT is offline  
Sponsored Links
Status: - Update
Posts: n/a
Had similar in my Fiat Stilo. The culprit was the motor that controls the flaps in the air box. One side had jammed and would provide hot or very hot air only. A chunk of carpet had got into the teeth of the gear and jammed them.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

climate , control , dual , problem , zone

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome