147 Head Unit iPod Connector - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 12-05-14 Thread Starter
Status: -
Join Date: Oct 2007
Location: Nottingham
Posts: 4
147 Head Unit iPod Connector

Having read various posts on this issue of connecting an iPod to the standard head unit, I'm seeking some advice.
My '05 Lusso didn't come with a CD Changer just what I assume is a standard single CD tuner head unit. I have purchased an Alfa iPod interface part no. 50903266 and connected it to the CD Changer port at rear of head unit. It powers and charges the iPod no problem and I know the iPod to be compatible, however the head unit does not recognise the iPod or CD Changer port.
I borrowed a head unit from a mate who has an '04 147 Lusso with a CD Changer in his boot and it worked fine allowing me to access the CD Changer and thus iPod. In fact even without the connection being made at rear of unit, his head unit scrolls through several options via the SRC button, such as fm1, fm2, fm3, LW, MW, CD Changer, CD, whereas my unit only displays Tuner and CD!
Is my head unit bust or is there something that needs configuring to bring up the greater range of options?

Any advice appreciated.
custard is offline  
Sponsored Links
Status: got a new busso s.w.
AO Silver Member
gibot123's Avatar
Join Date: Aug 2013
Location: United Kingdom
County: East Sussex
Posts: 1,670
Is your mates the same model head unit
If so it sounds like yours has a problem .
If it's an earlier model you may have compatibility issues as the later ones are designed to run mp3 compatible files.
The only thing with some of the units is they need to be coded to the head unit the cd changer I'm talking about as this was to stop them being pinched and plugged straight into another head unit so not sure if this might be a problem
Sorry can't say more than that
gibot123 is offline  
Status: -
AO Member
Join Date: Jun 2012
Location: United Kingdom
County: Northamptonshire
Posts: 543

Member car:

Alfa GT JTDm

1) go to the ice forum, search for the member "shiny car" and pm him with all your questions

2) If none of what he says works/u can't be bothered fading with the part you have, get a connects 2 instead or something similar - bargains to be had on the old bay I tell thee
Back2Alfa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , connector , head , ipod , unit

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome