156 JTD 16v MPG issue - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-05-14 Thread Starter
Status: -
AO Member
Join Date: Aug 2010
Location: United Kingdom
County: Cheshire
Posts: 42
156 JTD 16v MPG issue

I recently bought a 156 1.9 JTD but i'm having some issues with it particularly with fuel economy. I'm currently getting around 28mpg mixed driving (checked properly not off the display) I barely got 100 miles from 20 worth of fuel.

I have checked all the hoses, replaced the vac pipes, cleaned the map sensor, blanked the EGR valve and unplugged the maf sensor for a short time and run some injector cleaner through it. It was recently serviced so the Air filter, fuel filter etc are all new.

The only other thing I've noticed is that the thermostat is only getting up to around 65 degrees. I've got a replacement ready to fit but would a faulty thermostat effect fuel economy to this extent?

Scrompy is offline  
Sponsored Links
Status: got a new busso s.w.
AO Silver Member
gibot123's Avatar
Join Date: Aug 2013
Location: United Kingdom
County: East Sussex
Posts: 1,670
Sounds like the thermostat will be the first thing to change it thinks it's running cold
gibot123 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 16v , issue , jtd , mpg

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome