Selespeed help - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 03-05-14 Thread Starter
Status: -
Join Date: Nov 2013
County: -
Posts: 3

Member car:


Selespeed help

After some advice, had no idea which section to stick this in as it isn't an Alfa I have, it's a Fiat Stilo Abarth 2.4.

Having Selespeed pump issues. Few months ago car started dropping into N when coming to a stop/slowing. Turning on & off would get it back, or it would correct itself on its own after a few mins. Pump was still priming on door opening & every few gear changes. Got progressively worse over a few days until pump stopped altogether & car stuck in N.

Second hand pump was put in & all worked fine for approx 2-3 months (about 1k miles) now car is getting stuck in N again - pump still priming when door is opened however it lasts for 10+ seconds. Took it for a diagnostics & was told pressure dropped very low & bounced back up again when pump was hit. So it's looking like I need another pump.

Have I just been really unlucky & the second hand pump was just knackered or could something else that is being overlooked be causing my pumps to die so quickly?

On another note, do the Alfa selespeed pumps fit in a Fiat? They're a LOT cheaper!
matt28781 is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,994
I'm sure the pumps are different.
If they were the same, they would be the same price.

I'd never consider a s/h pump, they are too high a failure item to do that.
David C is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome