Lambda Sensor 156 JTS - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 26-04-14 Thread Starter
Status: -
AO Member
Join Date: Dec 2012
Location: United Kingdom
County: East Sussex
Posts: 53

Member car:

156 jts lusso

Help Lambda Sensor 156 JTS

Hi, Is this a regular problem with the JTS . Last year I had to replace a Lambda Sensor, bank 1 Sensor 2 . The car had only done 7000 miles, I thought they were supposed to last 60,000 miles .
Motor system failure has been up for months . So I have just had an MOT , and the garage says an other Lambda sensor is on its way out.
The car has now done 11,000 miles
Is there a fix to this ? there is 4 lambda sensors in a jts . Do I have to seek an Alfa Specialist ?.
They charged 210 for the sensor last time.
And of course motor system failure is back up again !
Any advice please ,Thank You
johnromeo is offline  
Sponsored Links
Status: Alfa nut
AO Silver Member
Join Date: Dec 2011
Location: United Kingdom
County: East Sussex
Posts: 1,271
They are prone to failure also the connectors on the upper ones can be suspect.They are a simple enough item to change and can be had on ebay at a "fair" price.
jim hazell is offline  
Status: -
AO Member
alfanano's Avatar
Join Date: Jun 2002
Location: I would rather not say
County: -
Posts: 782
Images: 6

Member car:


Loads of posts on 156 JTS MCSF - don't always assume that the component is at fault, it might be a problem with the connectors (especially if there are no other symptoms). I recall the lamba sensor connector suffers from being close to the exhaust - having said that I would have thought things like that would have been fixed on cars that are still around.

The other main culprit is often the large multi-connectors between the the back of the engine and the bulkhead.
alfanano is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , jts , lambda , sensor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome