Blimmin problems on 147, HELP!!...... - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Member
Join Date: Jul 2006
Posts: 23

Member car:


Re: Blimmin problems on 147, HELP!!......

My 147 has always had sluggish windows, they tend to stop half way up and i have to push the button to continue. My battery is fine, but it seems that its always worse in the wonter or cold conditions, which suggest that the window mechanisims are no good as they cant perform under low tempratures.

As for the errors, i def need a body computer and it will be replaced soon.
ALFAKAM is offline  
Sponsored Links
Status: -
AO Member
crazymoon4's Avatar
Join Date: Jan 2007
Location: Zumerzet
Posts: 336

Member car:

Alfa Romeo 147

Re: Blimmin problems on 147, HELP!!......

car went in on mon, new battery, all systems go! the garage freed the windows up a bit to, they go all the way now!
crazymoon4 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , blimmin , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome