alfa 156 airbag light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Reply
 
Thread Tools
(Post Link) post #1 of 56 Old 07-12-06 Thread Starter
Status: -
Newbie
 
Join Date: Dec 2006
Posts: 1
alfa 156 airbag light

the airbag light is on in my car, is this a common fault and can i reset it
mattbfc2386 is offline  
Sponsored Links
Advertisement
 
Status: Gold Member
AO Gold Member
 
rarebear's Avatar
 
Join Date: Sep 2002
Location: The Netherlands
Posts: 6,991
Re: alfa 156 airbag light

this is very common ! bad connector under passengerseat mostly, reset yourself ? no you need the examinator box , the Alfa dealer has one.
rarebear is offline  
Status: -
Newbie
 
Join Date: Dec 2005
Posts: 6

Member car:

156

Re: alfa 156 airbag light

Beware, when airbag light stays on, the airbags are disabled!!
156Silver2 is offline  
Status: -
AO Member
 
russ's Avatar
 
Join Date: Nov 2006
Location: United Kingdom
Posts: 101

Member car:

156 selespeed

Re: alfa 156 airbag light

Airbag light will remain on if the passenger airbag is de-activated - There's a slot for your key to activate / re-activate this in the passenger door opening.
russ is offline  
Status: belts, w/pump and cam sensor changed!
AO Gold Member
 
gazza82's Avatar
 
Join Date: Jan 2003
Location: United Kingdom
Posts: 7,652
Images: 12
Re: alfa 156 airbag light

There are two airbag lights: one for the overall system (which is the one likely to be the one on now) and the other to indicate the status of the passenger airbag. The Key slot is to activate/deactivate the passenger airbag when you have a reverse-facing childseat.

It doesn't reset the system though - you will need to hook it up to the diagnostic system.
gazza82 is offline  
Status: -
AO Member
 
Join Date: Dec 2006
Location: Costa del Sandancer
Posts: 14
Re: alfa 156 airbag light

That's oneof the faults mine has - I've only had it a week. When I test drove the car, it had to be started off a booster. A new battery was subsequently fitted and the lights reset. However, upon collection, the passenger airbag light was flashing quickly. The car has had to go back for a gearbox problem and is being looked into.

It would appear that the fault is a liitle more deep seated on mine as simply resetting the light does not make it go away. With the passenger airbag active or deactivated the light stays on. The car has been taken to an Alfa specialist, so I 'm sure it's going to get sorted.

Interesting to hear about the passenger seat sensor though.

Cheers,

Dougy
dougy is offline  
Status: belts, w/pump and cam sensor changed!
AO Gold Member
 
gazza82's Avatar
 
Join Date: Jan 2003
Location: United Kingdom
Posts: 7,652
Images: 12
Re: alfa 156 airbag light

Jump starting an Alfa can cause electrical problems .. sounds like they may have fried the airbag ecu!
gazza82 is offline  
Status: Gold Member
AO Gold Member
 
rarebear's Avatar
 
Join Date: Sep 2002
Location: The Netherlands
Posts: 6,991
Re: alfa 156 airbag light

There is a sensor pad in the passenger seat, you can feel it when you move you fingers on the seat, feels like little buttons, its a plastic sheet with sensors (costs a bundle to replace because the upholstery has to be taken off !!).
rarebear is offline  
Status: -
AO Member
 
Join Date: Oct 2007
Posts: 15

Member car:

Alfa 156

Thumbs Up Re: alfa 156 airbag light

The Flashing second (passenger) airbag light indicates that somebody has tampered with the airbag failure light. I know because that is what happened when I unsoldered the main airbag LED in order to get my car through the MOT (thought it might fail if tester noticed air bag failure) Anyway, soon as I unsoldered the LED the other one started flashing rapidly.
Andyfear is offline  
Status: -
Unregistered
 
Join Date: Oct 2008
Location: Ireland
Posts: 4,646
Re: alfa 156 airbag light

unidiag or alfadiag can be used, in conjunction with aKKL interface to reset the airbag system
SEARs is offline  
Status: -
AO Member
 
Join Date: Nov 2008
Location: United Kingdom
Posts: 11

Member car:

Alfa 156

Re: alfa 156 airbag light

Hi to you all. Does someone who lives in bedfordshire or surrounding areas have an alfa diag kit that they would be willing to reset my air bag light for me?.
Cheers Jas..........
bluejas101 is offline  
Status: -
Club Member
 
GTA Jim's Avatar
 
Join Date: Apr 2007
Location: Holbeach
Posts: 14,574
Images: 3
Re: alfa 156 airbag light

Quote:
Originally Posted by bluejas101 View Post
Hi to you all. Does someone who lives in bedfordshire or surrounding areas have an alfa diag kit that they would be willing to reset my air bag light for me?.
Cheers Jas..........
This might not be the best place to post this request matey, maybe put it in your regional lounge
GTA Jim is offline  
CJO
Status: Enjoying a nice mug of tea
AO Silver Member
 
Join Date: Oct 2008
Location: United Kingdom
Posts: 1,752
Re: alfa 156 airbag light

Quote:
Originally Posted by bluejas101 View Post
Hi to you all. Does someone who lives in bedfordshire or surrounding areas have an alfa diag kit that they would be willing to reset my air bag light for me?.
Cheers Jas..........
Go and see the guys at Auto Lusso - near Dunstable.
CJO is offline  
Status: -
Club Member
 
GTA Jim's Avatar
 
Join Date: Apr 2007
Location: Holbeach
Posts: 14,574
Images: 3
Re: alfa 156 airbag light

I should have thought of that
GTA Jim is offline  
Status: -
Unregistered
 
Join Date: Oct 2008
Location: Ireland
Posts: 4,646
Re: alfa 156 airbag light

Quote:
Originally Posted by mattbfc2386 View Post
the airbag light is on in my car, is this a common fault and can i reset it
there are TWO airbag lights:

* RED in the 'info-centre' is the main system light, if on the Entire airbag system is disabled.

* Yellow in the Speedo means that ONLY the passengers side airbag disabled symbol...... there is a key switch at the side of the glovebox/dash

to communicate you need software from either AlfaDiag Alfa Romeo Diagnostic Software or KWP71 from the yahoo/unidiag forum & a KKL interface from ebay.
SEARs is offline  
Status: -
AO Member
 
Join Date: Nov 2008
Location: United Kingdom
Posts: 11

Member car:

Alfa 156

Re: alfa 156 airbag light

Hi, Thanks I'm off to Dunstable. sorry if I upset anyone. Cheers Jas....
bluejas101 is offline  
Status: 2016 . . . .Year ofthe Sprint??
AO Silver Member
 
StescoG66's Avatar
 
Join Date: May 2007
Location: United Kingdom
Posts: 3,153
Images: 17
Re: alfa 156 airbag light

In my car it's the connector in the boot that causes the problem. Check the wee panel on the rhs of the boot and clean those connections.
Worked for me - just be careful when you do so
StescoG66 is offline  
Status: -
AO Member
 
Join Date: Jun 2009
Location: United Kingdom
Posts: 26
Images: 1

Member car:

Alfa 156 TS

The airbags are NOT disabled, some people say they are but they aren't, the same goes with the ABS light. My 145 ABS light has been on for 2 weeks but ABS still works. Don't try the airbags out though!!
1988del is offline  
Status: [Too Long]
AO Silver Member
 
crespo2121's Avatar
 
Join Date: Oct 2008
Location: United Kingdom
Posts: 1,109
Quote:
Originally Posted by 1988del View Post
The airbags are NOT disabled, some people say they are but they aren't, the same goes with the ABS light. My 145 ABS light has been on for 2 weeks but ABS still works. Don't try the airbags out though!!
Sorry mate but if the airbag light is on it means the system is dissabled.
And if the car has been jump started in then you have more than likely fried the airbag ecu.
Happened on both my 156's.
Sounds like your abs light is faulty.
When my ABS light came on (blown fuse) the ABS defo did not work.
crespo2121 is offline  
Status: -
Newbie
 
Join Date: May 2008
Posts: 8
The airbags are NOT disabled. Last november i collided with my 156 and yes airbags worked as they should even with airbag warning light on.
ronnande is offline  
Status: -
AO Member
 
machvingtsun's Avatar
 
Join Date: Sep 2008
Location: Ireland
Posts: 75

Member car:

156

According to Elearn the airbags may be disabled if the airbag warning light is on.
machvingtsun is offline  
Status: Gold Member
AO Gold Member
 
rarebear's Avatar
 
Join Date: Sep 2002
Location: The Netherlands
Posts: 6,991
Quote:
Originally Posted by ronnande View Post
The airbags are NOT disabled. Last november i collided with my 156 and yes airbags worked as they should even with airbag warning light on.


IMPOSSIBLE !!! when the AB light is on there is no power to the crash sensor and thus
no reaction .... you must be that one in a million case !
rarebear is offline  
Status: -
Unregistered
 
Join Date: Oct 2008
Location: Ireland
Posts: 4,646
if the RED light is on the system is dis-abled.

if the yellow is on ONLY the passenger side is disabled
SEARs is offline  
Status: Suspension Replaced - Next!
Club Member
 
TOX1C's Avatar
 
Join Date: Aug 2004
Location: South Wiltshire UK
Posts: 3,847
Images: 5
Quote:
Originally Posted by StescoG66 View Post
In my car it's the connector in the boot that causes the problem. Check the wee panel on the rhs of the boot and clean those connections.
Worked for me - just be careful when you do so
Same for me, last time the light came on I thumped the plastic cover in the boot and it went off and has stayed off, but having said that ................ there is always tomorrow!
TOX1C is offline  
Status: Suspension Replaced - Next!
Club Member
 
TOX1C's Avatar
 
Join Date: Aug 2004
Location: South Wiltshire UK
Posts: 3,847
Images: 5
Yup, true to form after 3 months or so without a light on, and after yesterday's post; YES you've guessed it the light came on today, went off, then on. Gave the same cover a few thumps - off it went, here's hoping for the best tomorrow.
TOX1C is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
156 , airbag , alfa , light

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome