Warning lights come on when I start my 147 JTD - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 01-12-06 Thread Starter
Status: -
Join Date: Dec 2006
Posts: 6

Member car:

147 TDI

Not Happy Warning lights come on when I start my 147 JTD

I've got a 147 JTD and it has just started having the problem of when I start the car a variety, or all of the warning lights come on from brake light bulb, ABS, EBD ASR and engine management computer.
If I re-start they eventually stay out and the computer says OK.
Sometimes the lights on the clock, mileometer etc go out and the rev counter goes to zero until I just move the key slightly then they work OK. On a couple of ocassions I have started the car put it into reverse and the engine cuts out. I've had the computer re-set but to no avail.
Anyone got any ideas? (just out of warranty by 2 months)

Last edited by chrisbob; 01-12-06 at 13:08.
chrisbob is offline  
Sponsored Links
Status: -
AO Member
Join Date: Sep 2007
Location: United Kingdom
County: Greater Manchester
Posts: 26

Member car:

147 JTD

Hi Bob,

did you get this sorted as i'm having very similar problems?


Tiddler85 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , jtd , lights , start , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome