156/147 Selespeed ECU compatibility - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 24-03-14 Thread Starter
Status: "Ruby" has been Torpedoed!
AO Member
bazzbazz's Avatar
Join Date: Apr 2013
Location: Brisbane Australia
County: Queensland
Posts: 207

Member car:

Alfa 156

156/147 Selespeed ECU compatibility

I am helping a young fellow get his "Bargain" 2001 Alfa 147 Selespeed up & running. The Selespeed ECU comes up with following error on both Alfa Diag & AlfaObd and it can't be cleared.

Error code: P1754
Loads relay
Probable cause: Solenoid valve faulty, Wiring faulty, Connections faulty, Wiring insulation, Poor contact of front right hand ground node connector C11 (resistance too high)The actual physical problem with the car is starts fine, s/SPEED pump works fine, S/Speed starts in neutral as it should, but when you put it in gear the engine stalls. Also cannot get any of the calibration routines to perform.

Anyone familiar with this problem?

It Does say when the details are brought up that its an internal ECU problem & may be a "driver" failure.
So tomorrow morning I am hoping it will turn out to be faulty connection somewhere. If it IS the ECU, we have a complete 2001 Alfa 156 Selepeed as spares. Does anyone know if the 156 ECU is interchangeable with the 147? Both cars use the same model Selespeed actualtor and same year.

Thanks in advance
bazzbazz is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

compatibility , ecu , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome