Mileometer LCD disappeared, spooky - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 25-11-06 Thread Starter
Status: -
Join Date: Aug 2006
Posts: 4

Member car:

156 1.8 T-Spark

Mileometer LCD disappeared, spooky

Help Please.

The LCD that displays the miles and outside temperature no longer lights up. I have checked the fuses, well the obvious ones, the manual doesn't tell me which specific fuse it is, but they all seem ok. Can the LCD just fail, has anyone had this happen to them. Everything else seems to work.
If anyone has any idea please let me know, i would be very grateful.

barloni is offline  
Sponsored Links
Status: Quo
AO Silver Member
harleyriv's Avatar
Join Date: Jan 2006
Location: Tuvalu
County: -
Posts: 4,706
Images: 19
Re: Mileometer LCD disappeared, spooky

They can fail but it's get it checked by a dealer..
harleyriv is offline  
Status: Breraless :(
AO Platinum Member
Squadrone Rosso's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 29,893
Images: 45
Re: Mileometer LCD disappeared, spooky

Could just be a bulb on the rear of the speedo. Easy job to sort
Squadrone Rosso is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

disappeared , lcd , mileometer , spooky

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome