156 2.0 TS ticking noise - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 10-03-14 Thread Starter
Status: -
Join Date: Mar 2014
County: -
Posts: 1

Member car:

156 2.0 TS

156 2.0 TS ticking noise


The car is Alfa Romeo 156 2.0 TS '98

I've read many threads regarding to this problem in this forum (which i'm very thankful for) and the most common fault was cracked manifold. I wonder if any of you had the same problem, since I uploaded the sound capture from my engine, please take a listen and let me know if it's really manifold or something more serious.

Some more information:

If i increase rpm very slowly I can pass this ticking noise, however if i do it as in those videos, you hear what happens.


20140310 142118 - YouTube

20140310 141245 - YouTube

Any information and thoughts will be much appreciated!
nkv is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , noise , ticking

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome