Choke control - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 09-11-06 Thread Starter
Status: -
AO Member
Join Date: Feb 2006
Posts: 445
Choke control

My 156 had its MOT last week and the tester who i know said that the emmisions were all over the place and only just passed. He rekons that the choke keeps intermitently comming on and off, over about the past month i have noticed the car not idling right like it would do if the MAF was gone but thats fine im sure as it is only 4 months old. Also now, when car is stationalry the tickover after car is fully warmed up is 1500rpm and sometimes as much as 2000rpm, ive found the only way to make it return to a normal idle at about 900rpm is to tap the throttle quickly and it will return.

Any ideas people, as i dont want to do any damage to the engine, and its driving me mad, thanks for any replies.
superturismo is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: Choke control

lambda sensor..
dodgy MAF, disconnect and run, see if it makes any difference..
sticky throttle valve..


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

choke , control

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome