156 V6 problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 03-11-06 Thread Starter
Status: -
Join Date: Nov 2006
Location: Surrey
Posts: 1
Help 156 V6 problems

Having recently been given an ***** 156 as a hire car, I decided to buy one as I loved the car. Unfortunately the one I have bought is causing me some trouble and I am in need of any help possible.

After owning the car for 2 weeks I broke down and the garage I took it to found the engine was flooded with petrol as there was an electronic error leaving the fuel continually pumping through. They replaced the ECU (At a cost!) and it seemed to have done the trick but shortly after getting the car back it has started to judder and does not seem to be firing right. Ocassionally it is fine and comes and goes.

You may guess from my description I am no mechanic! If anyone has had similar experiences or can offer any advice I would be very grateful.

The car is a 98 156 V6.


mbrogan is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
Re: 156 V6 problems

You may want to change the spelling from "*****" to "Alfa"...!

Re your V6 problem, do you know when the sparkplugs were last changed?
It could also be a coilpack starting to fail.
David C is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome