147 2.0 selespeed Problem. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 28-10-06 Thread Starter
Status: -
Join Date: Oct 2006
Location: London
Posts: 1
Not Happy 147 2.0 selespeed Problem.

hi, yeah im new to this forum..

recently i had a crankshaft problem on my 147 2.0 selespeed 2001 model.

Anyway i had the engine changed at a private garage not an alfa romeo delaer, everything has been fitted but the garage has been unable to restart the car.. Whenever the ignition is switched on or someone tried to start the car it turns over as if it wants to start but will not.. and it displays on the screen Immobiliser Faliure, VDC Faliure then Selespeed System Faliure and the car will not start it just tunrs over as if its trying to..

Also the little key-code icon appears aswell.. Any ideas on the cause of this or the solution. Before changing the engine the car never once had a problem starting or any immobiliser faults. The same ECU and everything is being used the parts replaced were the clutch and engine block. ive been advised to get the immobiliser key code from alfo which im going to on monday.

I dont want to have to start shelling out to an alfa dealer for a diagnostic test. the local garages disagnostic isnt showing up any faulty connections or sensors..

any ideas what it could be i nor the mechanic has a clue.
strictly_b is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,997
Re: 147 2.0 selespeed Problem.

It does sound like it is a problem with the immobiliser.
Usual problem is poor connection between the aerial around the key barrel and the code ECU under the dash.

If it starts ok using the emergency start procedure (once you have the required code) then that is the probably cause.
David C is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , problem , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome