156 Selespeed starting problem - injection failure light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 28-10-06 Thread Starter
Status: -
Join Date: Oct 2006
Posts: 2

Member car:

156 Selespeed

156 Selespeed starting problem - injection failure light

Hi, Can anyone shed some light on this problem?
In the last 10 days my 156 Selespeed failed twice to start. Both times injection failure light came on. Both times I tried 20 -30 times cranking engine but it would not start. After an hour's time of trying various starting techniques like cranking immediately without waiting for diagnostics it started. On both occasions the outside temperature was ~ 13C. It hasn't happened when warm but I do notice sometimes that the injector failure light flashes on. I need to ask around first as going back to the dealer ends up in loss of car for several days, a lot of money down the drain and the problem usually not resolved.

Cheers Marek
marek is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
Re: 156 Selespeed starting problem - injection failure light

If the engine is getting as far as actually cranking, then you can be sure it is nothing to do with it being a Selespeed.

So you then need to look at normal engine stuff, ie Fuel Pump, fuel pump relay, injection relay, TDC sensor, camshaft sensor, etc..
David C is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , failure , injection , light , problem , selespeed , starting

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome