156 balance shafts - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 25-10-06 Thread Starter
Status: -
Join Date: Oct 2006
Posts: 3

Member car:

Alfa 156

156 balance shafts


having a few problems with balancer shafts on my 156 Selespeed, appears a bearing is going and to fix needs engine strip to fix. My mechanic tells me the balancers don't make much difference ?
was wondering if I should just have the balancer belt off and run without the balancers ?
Anyone tried running without them and what difference does it make

jameskerry is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: 156 balance shafts

my 1.8 dosen't have them in first place...but if memory serves me right a few 2.0ltr owners don't run with them with no ill effects....have a search up top dude

Status: On Alfa number 15
AO Platinum Member
symon's Avatar
Join Date: Dec 2005
Location: United Kingdom
County: Oxfordshire
Posts: 33,578
Images: 13
Re: 156 balance shafts

You can run without them but IIRC you need to lock them in place to stop them turning. The engine will rev up faster without them due to less inertia, this is the main reason why they are often not used.
symon is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , balance , shafts

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome