Alfa 156 electric cooling fan inoperative - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 22-10-06 Thread Starter
Status: -
Join Date: Sep 2006
Posts: 4

Member car:

alfa spider S4

Alfa 156 electric cooling fan inoperative

The fan on my 156 2 litre has stopped working today.

Relay seems to be ok and I can run the fan by shorting out the blue and red wire to earth.

does anyone know what switches this fan on ?

There does not seem to be a sensor in the radiator as I would expect.

stevie is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,993
Re: Alfa 156 electric cooling fan inoperative

The fan is switched by the ECU.
It can be triggered with the Examiner and some other diag systems to help find the fault.
David C is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , cooling , electric , fan , inoperative

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome