Dodgy brakes on 147 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 08-10-06 Thread Starter
Status: -
Join Date: Oct 2006
Posts: 4
Help Dodgy brakes on 147

Rather alarming fault has recently appeared on my 147. Brakes seem to be applying themselves with considerable force (with only minimal pressure on the pedal) if applied when negotiating a bend, not necessarily at speed, regardless of road conditions. This is accompanied by a loud juddering sound from the front of the car, and a loss of resistance to the travel of the pedal. Absolutely terrifying when it happens, fortunately rest of family not in car at the time.

Anyone had any similar experiences? Is this just over-sensitive traction control? Car now well out of warranty, so should I brace myself for a big bill?
jpgolding is offline  
Sponsored Links
Status: -
AO Silver Member
marko's Avatar
Join Date: Jan 2006
Location: United Kingdom
County: Tyne and Wear
Posts: 2,736
Images: 4
Re: Dodgy brakes on 147

sounds like possibly the ABS kicking in for no apparent reason, i seem to remember someone mentioning something about faulty ABS sensors... dont know for sure tho. wouldnt imagine new sesor being hugely costly.

i trust someone will be along soon to give a better answer tho!

by the way, welcome to the club, get some photos of a alfa up!
marko is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , brakes , dodgy

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome