Headlight bulb clip - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 07-02-14 Thread Starter
Status: -
AO Member
Join Date: May 2011
Location: United Kingdom
County: Nottinghamshire
Posts: 149

Member car:

147 2.0 Lusso

Headlight bulb clip

I've just noticed that one of my high beam headlight bulbs isn't working properly, on closer inspection it appears the metal clip holding the bulb in is missing and some clown has tried using blu tac to wedge it in position! If anybody has a headlight unit that's buggered but still has the high beam bulb clip, any chance you can help me out?
Chris_derby is offline  
Sponsored Links
Status: - Update
Posts: n/a
They are a generic clip used in loads of cars. The one on the main beam of my 156 was bent and broke when I tried to un-bent it. I used one I had off the back of a Ford Focus cluster I had in the garage. Take the good one off, go to a local breaker and ask for one the same size. It'll be a quid or so .

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

bulb , clip , headlight

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome