2.4 20v fit in a GT - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 05-02-14 Thread Starter
Status: -
AO Member
Join Date: Sep 2007
Location: Runcorn
Posts: 32
Images: 2
2.4 20v fit in a GT

Well I've just had my beloved 156 2.4 20v Veloce written off, the insurance messed me about a bit with what they offered to replace it, so I've decided the take the car back and make the extra money by stripping it if the parts. I do fancy a GT but also love the sound my 2.4 makes, is it possible to fit the 2.4 20v engine in a GT?
Robbied3879 is offline  
Sponsored Links
AO Gold Member
davealfa11's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Merseyside
Posts: 9,904
Images: 4

Member car:

156 1.9 mjet 16v

buy a brera
davealfa11 is offline  
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,995
Racing GT have been built with 2.4JTD engines, so it does fit (just!).
Not sure if anyone has done it on a road car though, which is a lot more complicated.

But yes, buying a Brera is a lot easier.
David C is offline  
Status: 1750TBIecusoftware.. done!.40+bhp
Join Date: Jan 2009
Location: United Kingdom
County: Merseyside
Posts: 3,480
Images: 10

Member car:

various Alfas

It will fit,but it is a LOT of work ,not so much from the mechanical side but the electronic.Much easier and cheaper to get another car.
ALFA TUNER is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

20v , fit

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome