fault codes p0141, p1177 and p1178 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 27-01-14 Thread Starter
Status: -
AO Member
mick45672's Avatar
Join Date: Apr 2007
Location: Cirencester
County: -
Posts: 38
fault codes p0141, p1177 and p1178

on my 51 plate 147 2.0 got a bad sensor reading of p0141 (o2 sensor heater curcuit bank 1 sensor 2) wich i know is lambda sensor

to check i had the right lambda i unplugged the offside precat (bank 1 sensor 1) that threw up a code relating to correct sensor cleaned contacts with contact cleaner

then checked nearside as i thought threw up bank 2 sensor 1 fault once again cleaned

then unplugged third sensor wich threw up bank 1 sensor 2 fault (p0141) so now i know wich sensor / connection is faulty (ok pace palm we are dealing with alfas here)
clean all connections dry them right out from the solvent replug everything should be good

drive up road about 6 miles flick up fuel consumption and at 60mph am doing 16mpg
about 500 yds further on engine managment light comes on so i flick up torque and show fault codes p0141 (ok i know this one so post cat lambda is busted), also new codes are p1177 and p1178

now been reading forums and there seems to be confusion over these codes could they be where i cleaned the precat sensors (so i need to take em apart reclean and check properly) OR is it more likely to be the MAF sensor gone as well?
mick45672 is offline  
Sponsored Links
Status: -
Join Date: Dec 2013
Location: United Kingdom
County: Oxfordshire
Posts: 223

Member car:


Just replace the post cat sensor.
Smellysocks is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

codes , fault , p0141 , p1177 , p1178

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome