I've sold my GT! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Wave I've sold my GT!

After 2 and a half years of ownership I have sold my GT. I loved and hated it in equal measure. Never have I owned a car that has broken down and had as many quirks as this car did. No matter how well maintained I kept it there was still constant issues. I eventually lost patience having replaced the front wishbones twice and after only a few months they began creaking again. As annoying as owning it had been I was still sorry to see it go.
Anyways thanks to all the advice from various members down the years, without this site I wouldn't have lasted as long as I did!

Good luck to everyone else, I'm glad you lot own the cars and I will just be content to admire from afar (unless it's a hatch back, still think they're minging)

Sponsored Links
Status: -
AO Member
belavia's Avatar
Join Date: Aug 2011
Location: Australia
County: New South Wales
Posts: 658
Images: 6
Sorry to hear your going, just a couple of questions. How many miles did you do on the car in the 2.5 years? And what are you driving next?
belavia is offline  
Status: -
AO Gold Member
Wezley's Avatar
Join Date: Sep 2011
Location: United Kingdom
County: Greater Manchester
Posts: 11,402
Images: 27

Member car:

159 2.4 JTDm

Mine has never broken down or let me down but I agree on the cheese made suspension
I use an old Audi A4 half the time so despite having it a while I've not used it much I guess!
Wezley is offline  
Status: - Update
Posts: n/a
I put about 17,000 miles on the GT in the time I owned it, have another car for weekends and leisure.
My new car is a Lexus IS220d, 2006 with only 34,000 and a full lexus dealership history. Was a bargain at £7000.00
No where near as pretty as my GT but is better equipped and a more reliable car, hopefully. I will keep it fully serviced and hope to avoid the surprise bills my Alfa was constantly presenting me with.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome