Overheating problem fixed (but have a quick question?) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-09-06 Thread Starter
Status: -
AO Member
Join Date: Sep 2006
Posts: 16
Overheating problem fixed (but have a quick question?)

Hi Guys

A few weeks ago i put a post on here about my 156 overheating - see link below.


Well, its now been fixed and it turned out to be the waterpump - impellor was spinning on its thread. I've also had the thermostat and radiator changed at the same time.

Before the problem the temp gauge would sit at around 70 degrees, only rising to around 90 in traffic at which point the fan would cut in. It now seems to sit nearer 90 but is constantly moving no matter if im cruising at 70 or going with traffic - it seems to rise to 90, then fall to around 70, rise again etc..... is this the thermostat opening and closing? I thought the thermostat just remained closed when the engine is cold and was pretty much open for the rest of the time?

Any thoughts would be appreciated.

Many Thanks - Mike
Mike Sprague is offline  
Sponsored Links
Status: Fixing all your keys !!
AO Silver Member
Chris's Avatar
Join Date: Mar 2001
Location: United Kingdom
County: Tyne and Wear
Posts: 3,806
Images: 2

Member car:

a very dirty car

Re: Overheating problem fixed (but have a quick question?)

It sounds a bit like the thermostat is sticking, but it is a bit puzzling. I wonder if you have a major airlock but the system is supposed to be self-bleeding . On balance I`d say the thermostat needs poking about with, maybe even trying another one.
Chris is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

fixed , overheating , problem , question , quick

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome