Blaupunkt 10 cd changer - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 22-01-14 Thread Starter
Status: -
Join Date: Jan 2014
Location: United Kingdom
County: Hampshire
Posts: 1
Blaupunkt 10 cd changer

Hi all!
My blaupunkt 10 cd changer In my alfa romeo gt 55 plate will not eject, play or even show on my headset does anyone know how to resolve this or what the issue could be? Thanks for your time and help in advance!
Nickrs90 is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Feb 2009
Location: United Kingdom
County: Cambridgeshire
Posts: 1,519
My son had the same CD changer in his Punto, same thing happened, it was completely dead, I sourced him a replacement on eBay for 50 but he didn't want it, you'll find a few on there with the same issues for spares.................

Bin it and get a new head unit with usb, ipod, etc capability.
twincamms is offline  
Status: Thinking about giulia veloce
Club Member
Membro Premio
jwq's Avatar
Club Member Number: 857
Join Date: Jan 2005
Location: The Netherlands
County: Zuid Holland
Posts: 4,103
Images: 16
Is it getting power ? Check the fuses (and connector) ....
jwq is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

blaupunkt , changer

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome