V6 Flat spot at 5000rpm - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-08-06 Thread Starter
Status: -
AO Member
Join Date: Aug 2006
Posts: 14

Member car:

156 2.5 V6

V6 Flat spot at 5000rpm

Hi again guys.

Right today was the first chance ive had to drive my new alfa since receiving it last week. (sorting out tax, insurance). Im smitten, i love the sound and the handling.

Had a few looks off other drivers, one guy who was behind me in an audi S3 looked intrested. Prob to do with the fact its got a whopppin great spoiler on the back!

Anyway, it pulls niceley in all gears to about 5000rpm where it seems to go flat rite up to the 7000 limit? Only done 40,000 miles so has anyone got any ideas why?

Thanks again

Turbochops is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: V6 Flat spot at 5000rpm

could be your Air Flow Meter or MAF...try disconnecting it and see whether it makes any difference to the rev range/idle, if not it may need attention...you can either give it a clean or purchase a new one... to clean, from a previous thread:

Remove the MAF - undo the metal clips with a pair of small pliers or lever off with small screwdriver, undo the cable tie which keeps the connector cable tidy to the air duct.and then the connector remove the MAF.

There are 2 TX secrurits screws that clamps the sensor to the MAF body...these can be undone with pliers as they are not to tight.

Pull the sensor head out and stick the MAF body a bowl of luke warm water and slosh about...use a sponge to clean the inside of the MAF body but do not touch the Mesh. then put back in the bowl and leave for about 20 Mins...

To clean the sensor head you need anti-static cleaner from Maplin or any radio hobby store..

Spray liberally all over the head......

You will see a channel in the sensor head, and will notice a wire running inside....you can clean this with a cotton swab with cleaner applied.....don't go to mad just apply gentle pressure.

At the side of the sensor is a metal plate within another channel...you can clean this using the cleaner and some tissue, wedge it in the grove and slide in and out....you can use a small screwdriver to exert more pressure to clean the plate and the edges.

The sensor heads..electonics is sealed so dont worry too much...but still be carefull.

When this is done....rinse the sensor head under luke warm running water from the tap and just cover the top part of the head where you have cleaned...

when done remove the MAF body that was soaking, test the mesh for cleaness with a cotton swab, if still dirty use the anti-static cleaner to clean more..and re wash in luke warm water.

Lay both the sensor and the MAF body...on a tea towel on a radiater to dry naturally...

Re-Fit the MAF all back together and put back on the car.

or purchase one from :


or give fleabay a go

best of luck


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

5000rpm , flat , spot

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome