Is the 156 JTS 2002 2.0 a good car? - Page 3 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: TJR Valeting
AO Silver Member
Tommywho156's Avatar
Join Date: May 2012
Location: United Kingdom
County: Leicestershire
Posts: 2,267
Originally Posted by Smellysocks View Post
When you drive at a steady speed and smoothly then economy is at its best. And on that trip I averaged 48.6Mpg.
Not a chance you got anywhere near 48.6mpg unless you pushed it most of the way there.
Best I ever got out of mine was 35.2mpg. Were you getting your figures from the infocentre display? You do know it tells more lies than an Italian president don't you...
Tommywho156 is offline  
Sponsored Links
Status: wanted dead and alive!
AO Member
SchrodingersCat's Avatar
Join Date: Jan 2013
Location: United Kingdom
County: Norfolk
Posts: 450
I have a 100 mile round trip to work of mostly A roads with a bit of city and my JTS averages 34 mpg, my 146 will do 31 mpg. I've done the journey from Norfolk to South West Ireland (480 miles) several times on a single tank with the JTS giving 40 mpg.
SchrodingersCat is offline  
Status: -
Join Date: Sep 2016
Location: Switzerland
County: -
Posts: 3

Member car:

156 2.0 JTS SW

Originally Posted by Alfa156Melb View Post
I think they're great, I've had mine for 7 years and apart from a cam belt breaking, its never given me any problems..

The cam belts need doing every 60,000 kms by the way. (oh wait, did you mean 35,000 miles?)

All engines have their issues - I would say that the JTS can get coked up a lot, its best to use 98RON fuel and as you say, check the oil every week and make sure you run 10w60 full synth..

The other problem with them is that the crank is very soft, so never run the oil low.. never skip a service. Never yell at her.. she's sensitive.

Give it a good run every now and then to burn off any water and fuel in the oil if you do mainly short trips.. but when you do go on a long fast run - check the oil!! it will drop fast.

Otherwise, don't fang it when its cold - give that thick oil a chance to warm up and thin out before you put the foot down... should take about 15v mins and make sure you service it regularly...

I've upgraded my suspension and replaced anything that had a hint of being worn out and I have to say, she drives like new and she's lovely..

Oh - and the fuel consumption is excellent.. i get about 800kms to a tank. Compared to the GTA it's more like a prius! maybe not a good comparison...

Edit: reading my reply it sounds like its a full time job cuddling this car.. its not.. all you need to do is respect it, treat it kindly.... if you want to thrash it, warm it up first.. otherwise for me its been trouble and hassle free.
what an excellent post. thanks!
Conor_McG is offline  
Status: -
AO Member
Join Date: Mar 2014
Location: United Kingdom
County: Lincolnshire
Posts: 705
Originally Posted by Tommywho156 View Post
I never had a fault with mine and I will be buying another (the reason I don't have it anymore is because the ex ended up with it in the divorce and refused to sell it back to me!).
My biggest tip is to add a bottle of injector cleaner every 3 tanks, it'll help stave off those injector problems people often mention. Other than that keep to the proper service schedule and check the oil every week and enjoy the car.
Yes, funnily enough, i've always used injector cleaner in mine and its been absolutely fine, its also highly recommended by Autolusso, now these guys know what their talking about.

They are good cars when you know about the preventative maintenance, thats the key really
Ber Tony GT is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 2002 , car , good , jts

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome