Oil Presure Low - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 19-08-06 Thread Starter
Status: -
AO Member
Rowan's Avatar
Join Date: Jan 2006
Location: London
Posts: 21

Member car:

147 2.0 TS Lusso

Oil Presure Low

Under very hard braking, or very hard turns the managment system often pops up with a "Low Oil Presure" warning.

At a guess this is the oil simply getting thrown to one side, thus the sensor reads it as no oil. Its the fact that it says presure rather than level. Is thier a warning for oil level low as well?

Has any one else had this happen under what could best be described as vigorous driving?

The little beeb and flashing lights scare the hell out of me!
Rowan is offline  
Sponsored Links
Status: Quo
AO Silver Member
harleyriv's Avatar
Join Date: Jan 2006
Location: Tuvalu
County: -
Posts: 4,706
Images: 19
Re: Oil Presure Low

Hello Rowan - try this thread for some explanations.........http://www.alfaowner.com/Forum/alfa-...ht=sump+baffle
harleyriv is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

low , oil , presure

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome