156 Engine management system - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 15-08-06 Thread Starter
Status: -
Join Date: Aug 2006
Posts: 2
Madness 156 Engine management system


My Alfa 156 has recently had a new engine fitted. When I was driving home today it started to over heat a little and then the engine management light came on. Any ideas? Could it be the radiator needs topping up?

Ruffy is offline  
Sponsored Links
Status: Minus an Alfa.
AO Silver Member
Pete McK's Avatar
Join Date: Jul 2006
Location: United Kingdom
County: North Yorkshire
Posts: 1,699
Re: 156 Engine management system

Check the oil and water levels, plus make sure they have reconnected asll the electrics - like the fan wiring....
Pete McK is offline  
Status: -
AO Member
Join Date: Dec 2005
Posts: 164
Images: 6
Re: 156 Engine management system

Yeah sounds like there may be a problem with the cooling fan and this would cause the management light to come on.
kevs gta is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , engine , management , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome