Driver side wiper 147 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 11-08-06 Thread Starter
Status: -
AO Member
Join Date: Jun 2005
Posts: 23
Not Happy Driver side wiper 147

Weird thing happened this morning, turned on my wipers to clear some kamikazee bugs and the driver side wiper started making some funny noises. After closer inspection, it appears that the wiper is rubbing against the bonnet when it runs, and the wiper sticks out more than it should.
Has anyone had this before, and is it going to cost me a fortune?
razwanali is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: Driver side wiper 147

Couldn't you just unbolt the wiper arm
and put it back on a few notches clockwise ?
Status: -
AO Member
Join Date: Jan 2005
Posts: 657
Re: Driver side wiper 147

Be careful when unbolting - I did that and it cost me 250 in a new wiper set as I broke the wiper arm where it joins the motor! Thankfully the windscreen repair company fixed it for me

There is a wiper arm removal claw - either get that, or pop into your local windscreen repair centre and sweet talk them. Alternatively, go to Alfa for 80.......

Seriously, don't try to remove and adjust yourself unless you have the claw, and know how to use it.
Wilmslow is offline  
Status: -
AO Member
L9FFF's Avatar
Join Date: Jul 2006
Location: Norfolk, England
Posts: 25

Member car:

147 2.0 TS

Re: Driver side wiper 147

sounds like it might be the same problem as i had

is the wiper rubbing on the edge of the bonnet? and damaging the paint work?

the problem is maybe that the plastic linkage arm connection, connecting the driver side to passenger side wiper has broken/snapped!!
i believe there is two types of this assembly, the old one is all metal the newer one (from about 2001 onwards has a plastic link arm), youl need to find out which one you have.

mine was the newer one, if you have the older one this probably wont apply

if you pull the wiper away from the screen, it'l probably feel floppy and will rest against the bonnet
to fully check this out/replace you have to remove the wiper arm and then the black plastic cover's (they snap off okay once youve got one started but be carefull not to damage the windscreen!!) to gain access to the wiper linkage assembly underneath.

once youve got the driver side cover unattached youl be able to see underneath enough to see what the damage is!!

if the link arm is broken you will most likely need to replace the linkage assembly. this isn't too difficult just involves a coulple of holding screws and the motor electrical connection.

i couldnt manage to get hold of the assembly from a scrappy (approx 60-70) so had to buy from main dealer (ouch!!) which i think was about 120 and fitted myself
yeah very expensive for what it is considering if they would have made the link arm connection out of steel this probably wouldnt have happened!!

let us know how you get on!!

just smile!
L9FFF is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , driver , side , wiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome