alfa 156 sub and amp wiring - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 17-12-13 Thread Starter
Status: need help :(
Join Date: Dec 2013
Location: Australia
County: Victoria
Posts: 3

Member car:


alfa 156 sub and amp wiring

hello guys im new to this and i dont know if im putting this in the right spot if im not let me know but i would still like some help

so what im trying to do is run a power lead from my battery to my boot ive tried a few ways that ive read online but non have seemed to work

i have an Alfa 156 RHD sele speed sep 2009 model

help would be VERY appreciated dont really wanna pay a guy 150$ to do it if i can do it myself with help from you guys
fibroidjames is offline  
Sponsored Links
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
Welcome to AO . Ran my power piggy backed off the ignition barrel with a fuse next to it. It solved two problems for me. First I didn't have to get to the battery in the front of the car and second it isn't live when the cars ignition wasn't on so it wouldn't flatten the battery. Much better idea IMO. The took up the plastic trim at the bottom of each door and ran it behind the dash and down the left side of the car to the boot along with the wires for from the stereo. Earthed the sub on te boot floor. Worked for years like that.

BMW E12 M535i, JC racing diff, Gaz coilover, Powerflex.
Alfa 156 GTA, Q2, Super sprint, CF2, EQ, KW coilovers, Eibach rollbars, Powerflex.
Alfa Mito QV , BMC filter.

GitList Member but not as high as Keithy! No Gibbo....I don't need a haircut AO Troublemaker! You have been warned
Joss is offline  
(Post Link) post #3 of 3 Old 18-12-13 Thread Starter
Status: need help :(
Join Date: Dec 2013
Location: Australia
County: Victoria
Posts: 3

Member car:


hello thanks for the fast reply, btw i like the fact you like naruto so do it haha :P

just a quick question how do i connect my cable to the ignition barrel>>
fibroidjames is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , amp , amplifier , install , rhdrive , wiring

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome