Stereo Install Troubles - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 02-08-06 Thread Starter
Status: -
Join Date: Jul 2006
Posts: 4

Member car:

147 1.6 TS Lusso

Stereo Install Troubles

Hi All,

As the new owner of a 147 I am in need of some help upgrading the head unit on my car.
I have purchased a fascia adaptor and also an aerial adaptor and these are installed fine, however when coming to fit the unit itself I am having some problems.

I cannot get the radio cage to fit, I think the opening for this is too small or do I just need to force it? Currently the radio is in, but it can easily be removed just by a light tug. Also I am having issues with the stereo remembering things. I read that the Live and Switched live are wired in wrong on the 147, how easy is this to rectify?

Thanks for your help.

jimeney is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

install , stereo , troubles

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome