Catalytic Converter New 156? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 30-07-06 Thread Starter
Status: -
Join Date: Jun 2006
Location: Australia
Posts: 5

Member car:

156 Sportswagon

Help Catalytic Converter New 156?

Hi Everyone, adding to my woes of engine probs with brand new car had computer warning message just before w/e "motor control system failure". On the phone, garage reckons it's the catalytic converter. Everything is under warranty with only 1000kms on the clock, but how could this happen so early on? I noticed from the very beginning really oily black exhaust so wonder whether my JTS "lean burn technology" engine isn't performing as well as it should.

Probably gave everyone a heart attack traversing a 6 lane busy hwy last week when trying to zip across and experienced a significant lag in rpm response (did lift foot off clutch in case you're wondering!)

Downunder Maria is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , catalytic , converter

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome