Bit whiffy after a run - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 08-12-13 Thread Starter
Status: New 147 owner in Honeymoon period
AO Member
Join Date: Sep 2013
Location: United Kingdom
County: West Midlands
Posts: 22
Bit whiffy after a run

No, not me, I don't do exercise these days!

After I parked in a multi-storey earlier I got out and there was a distinct whiff of petrol. It was strongest from the rear which has me thinking maybe to check the venting - the petrol cap lock is also broken and I am wondering if that also has a seal problem. Can the lock mechanism in the cap be changed or is it easier to just get a new one - and can the seal be changed too?
Dainase is offline  
Sponsored Links
Status: -
AO Member
belavia's Avatar
Join Date: Aug 2011
Location: Australia
County: New South Wales
Posts: 658
Images: 6
Yes it could be the cap check video on youtube "does your car smell of gasoline" scotty kilmer

If its the same cap as an Alfa 156 2.0TS i can send one out to you, just pay me for postage cost, i think its around $20 australia for express. PM me if its the same
belavia is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

bit , run , whiffy

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome