couple more Q's on my sportwagon - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 05-12-13 Thread Starter
Status: -
AO Member
Join Date: Dec 2013
Location: United Kingdom
County: Gloucestershire
Posts: 10
couple more Q's on my sportwagon

Hi chaps, just wondering a few things...

What model turbo is my 156 1.9 115bhp?

Which button/switch works the headlight washers?

On key when you flip open key there's a little slot with lock unlock symbol, what does this do?

Bottom splash guard is literary hanging on for dear life, can I take it right off without any drawbacks? Looks rather tired and no more than inch off the floor.

Boot doesn't open on the key, you can hear something clicking but no joy, opens on the lever by drivers seat tho

Thanks in advance :-) Les
alfasportswagon is offline  
Sponsored Links
(Post Link) post #2 of 4 Old 05-12-13 Thread Starter
Status: -
AO Member
Join Date: Dec 2013
Location: United Kingdom
County: Gloucestershire
Posts: 10
And what boost do they make in standard form?
alfasportswagon is offline  
Status: Wiper and window motors getting on my nerves
AO Member
Join Date: Aug 2013
Location: United Kingdom
County: Staffordshire
Posts: 163
Headlight washers should work when the lights are on and you wash the screen
Think the unlock thing in the key is to open it to change the battery
You can remove the splashguard or do what I did and if it cant be fitted back because its split/cracked just drill new holes and cable-tie it back into place. You can run without but it will warm up quicker with it in place and also keep the engine bay cleaner
Sounds like a problem with the locking motor if it wont open on the key ( do you mean the remote or the key in the boot lock ? )
No idea on boost mines petrol :-)
capri_rob is offline  
Status: -
AO Member
Hugh Myles's Avatar
Join Date: Aug 2007
Location: Sligo, Ireland.
Posts: 790

Member car:

156 2.4 JTD SW

WD40 sprayed liberally on the mechanism, where the latch is, not the lock. If you open the tailgate and press the key a couple of times you should see the mechanism sliding across beside the latch, if its stiff, which it is, the motor does not have the gumption to move it fully, whereas the lever uses a cable. Not sure about boost on yours, but wondering why you'd like to know, is it giving trouble ? Not sure about the lock on the key either, never noticed it before, capri rob probably right, or it might be the ejector seat........
Hugh Myles is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

couple , sportwagon

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome