Need help or advice with my alfa 147 Selespeed - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 16-11-13 Thread Starter
Status: -
Join Date: May 2013
Location: United Kingdom
County: North Yorkshire
Posts: 3
Need help or advice with my alfa 147 Selespeed


I'll start from the beginning.

My alfa started causing me problems in the summer. It would overheat and jump from 2nd gear to 5th. It went to the garage, I asked them to flush the Selespeed fluid, as I'd looked up some similar problems on here. Instead they sent the brain off to get checked and it came back fine. They didn't do anything else.

It was okay for about 3000 miles. Then the Selespeed pump didn't kick in when I unlocked the door. Started the car up fine but it wouldn't select any gear at all.

So back to the garage. It's now had a reconditioned Selespeed pump fitted and the garage man has said that he'd flushed the fluid 3 times and replaced it with new fluid called Tutela. I have been told that the fluid that was in the car was for the power steering fluid, to my absolute horror.

Did a little test drive at the garage and everything seemed to be working. Until I was on my way home. Now the car jumps from 2nd to 5th again and it doesn't matter whether I'm in city mode or flappy paddles or stick.

I checked the Selespeed fluid level and that's fine but the new fluid is still very cloudy.

I can only think that it needs flushing more. Any advice?

Thanks in advance
sjkitch is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , advice , alfa , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome