156 2.5 V6 Question & parts - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 16-11-13 Thread Starter
Status: Now driving a 156 2.5 V6 24v
AO Member
Join Date: Jun 2011
Location: United Kingdom
County: Wiltshire
Posts: 150
Images: 4
Wave 156 2.5 V6 Question & parts

Hi All,
I was busy cleaning my 156 earlier and found an electrical connector disconnected under the drivers seat. There doesn't seem to be anywhere it plugs in to. The plug is black and the 2 wires are also black. The wires go up into the seat base. Any ideas what it does and where it should plug into?

Also, I have (another) 2000 W plate 156 2.5 which has died from terminal underbody floorplan rust. So if anyone is in need of parts then PM me.

And finally, I am after a pair of side skirts for my 156 saloon if anyone has some going.

Last edited by Karl702123; 16-11-13 at 17:14.
Karl702123 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , parts , question

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome