Power Steering Problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-11-13 Thread Starter
Status: -
AO Member
Join Date: Jul 2009
Location: New Zealand
County: Wairprarapa
Posts: 12
Power Steering Problems

I think I've got a power steering pump problem with my 156 2.5. Symptoms are screeching sound with steering straight ahead, moaning sound with heavy steering and some kick back when turning(screeching & moaning ... ooh err). Fluid level is between min and max but it has a good foamy head on it which I have not noticed before. I replaced the aux belt about 3 years (20 k miles) ago.

Is likely to be a pump on its way out?


Simon D is offline  
Sponsored Links
Status: Paint it black
AO Member
INS147's Avatar
Join Date: Oct 2010
Location: United Kingdom
County: Highlands
Posts: 551
Images: 4

Member car:


What colour is the fluid - as in is it 'dirty'?
If the fluid is a kind of dirty black (including the froth!) you might have a problem with the seals in the steering rack.
For me though the foaming is the key thing, it could be that it's being caused by the power steering pump drawing air past a worn seal or the rack itself drawing air through a knackered or leaking seal as the car changes direction.
Personally I'd top the fluid level up to max and with the car running get underneath it and have a look at the condition of all the rubbers etc and look for leaks around all the steering pipes and the rack itself. Carefully/gently have someone move the wheel from lock to lock and make a note of when the noise(s) are at their worst, it'll give you an inidication of where you need to look hardest.
Start with plenty of fluid.....

INS147 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

power , problems , steering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome