Selespeed crunch - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 25-06-06 Thread Starter
Status: -
AO Member
Join Date: Mar 2006
Location: United Kingdom
County: Wiltshire
Posts: 385
Selespeed crunch

My 03 reg Selespeed 2ltr has done 80k the problem I am experiencing is clutch judder on pulling away in 1st gear (not always) but more concerning to me is that when i change down from 3rd to 2nd gear there appears to be a loud thud.. you can feel this when changing down. This problem only manifests itself when the car is warmed up. I assume the oil in the gearbox is a bit more thinner when warm . Any ideas what I can check before I have to embark on some costly mission with a garage?

Any advise welcome..
Romek is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: Selespeed crunch

Mine has always crunched going from 2nd to 1st. Not from 3rd to 2nd though!

Sorry, not actually much help really!

Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,991
Re: Selespeed crunch

When was it last calibrated (full clutch push-rod and end-of-line Selespeed calibration)?

2nd-1st should only be attempted when the revs are very low in 2nd (ie 1000rpm), 3rd-2nd should be fine at any revs though.
David C is offline  
Status: missing Inverurie
AO Gold Member
Pascs's Avatar
Join Date: Apr 2002
Location: Qatar
County: Aberdeenshire
Posts: 8,063
Images: 16

Member car:

Zender 156 V6

Re: Selespeed crunch

The last time I had crunching going into 2nd gear from 3rd it turned out to be that a good flush of the Selespeed fluid and new fluid in and it was cured - also worth to get the system recalibrated at the same time.

(this was after the Alfa garage removed the gearbox even though I told them it was not a gearbox problem )
Pascs is offline  
(Post Link) post #5 of 6 Old 25-06-06 Thread Starter
Status: -
AO Member
Join Date: Mar 2006
Location: United Kingdom
County: Wiltshire
Posts: 385
Re: Selespeed crunch

Thanks for the info so far,

I had the clutch changed last year in May. The selespeed pump was also replaced at the same time. It was calibrated on the "examiner" at that time. No problem with 2nd to 1st gear only when going from 3rd to 2nd

Perhaps I should try with a flush of new fluid first.
Any idea were the drain for it would be?
Romek is offline  
Status: -
AO Silver Member
phil155's Avatar
Join Date: Jul 2005
Location: half way up the A12
Posts: 5,093
Images: 24
Re: Selespeed crunch

told ya

phil155 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

crunch , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome