Pick Up & Fuel Usage Problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 06-06-06 Thread Starter
Status: -
AO Member
Join Date: Jun 2006
Posts: 17
Hmmm Pick Up & Fuel Usage Problem

Hope someone can help.

(A little bit of background to begin with)!!
A few months ago, the injector light was continiously lit on my Alfa 156 1.8 (1999 - T). While this was on, the fan was running continiously too. I was told my "temp sensor switch" needed replacing and upon doing so, the two above problems went away.

However I have the following problems which may be related to the above and / or related to each other:

(1) When I am driving (at times) when the revs go up to 4000RPM, the car does not pick up speed and also the revs do not go any higher. However this mainly occurs when I press the peddle right to the bottom. If I lift my foot up slightly, the car picks up speed and also revs go up.

(2) Very very occasionaly (and surprisingly) one hill in the morning, as I am queing up this hill, when I try to set off, I cannot get the car to move as pressing the accelerator is having no effect on the revs. After a while it shoots off!!

(3) The car is taking up too much petrol, I am getting very low mileage for the amount of petrol I am putting in. Also when I park up after a journey, I can smell petrol / burnt fuel. I have taken it for an emission test and was told they were high.

Can anyone help? Has this anything to do with the injector light problem??

The only other thing I wish to add which may have no significance, is that whilst replacing the AIR filter, a couple of bolts snapped on the cover. This currently has not been replaced (the cover is still on but is not fully bolted down hence leaving insides exposed slightly) could this affect fuel to air ratio (if there is such a thing) The problem of picking up speed seemed to occur the same time as this air filter issue. Is this just a coincidence??

If there is any more info required please let me know. Hope someone can help!! A tube of Smarties for the person who helps me out!!

See Ya
SPARK-T is offline  
Sponsored Links
Status: Standby.........
AO Platinum Member
mr.orange's Avatar
Join Date: Aug 2004
Location: United Kingdom
County: Durham
Posts: 15,637

Member car:


Re: Pick Up & Fuel Usage Problem

if you do a search on the forum for MAF or air flow meter, it may help, it may not
mr.orange is offline  
Status: - Update
Posts: n/a
Re: Pick Up & Fuel Usage Problem

Try running a bottle of that injector cleaning stuff through, only fill to half a tank afterwards and give it some welly. Italian tune up!


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

fuel , pick , problem , usage

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome