Speedometer/odometer problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 04-06-06 Thread Starter
Status: -
Join Date: Sep 2004
Location: Mid Wales
Posts: 1

Member car:

Alfa 156 2.0TS

Speedometer/odometer problem

Hello all. The speedometer/odometer on my 2001 156 2.0TS has randomly started to fail. It usually happens within a few miles of a cold start. The speedometer will drop to 0mph and the odometer will stop counting miles. After about 5 minutes or so the speedometer usually springs back into life and stays that way for the rest of the journey. No warning lights come on while this is happening.
Is it true that the 156 gets its speed signal from the ABS computer?

Thanks in advance,
stephenmc is offline  
Sponsored Links
Status: cornea come l'inferno
AO Silver Member
Hoygaard's Avatar
Join Date: Apr 2002
Location: Denmark
Posts: 4,156

Member car:

156 GTA SW

Re: Speedometer/odometer problem

Yes, it's true. The ABS unit sends a speed signal to the speedometer. The speedometer then sends the speedsignal to the engine ECU and the climate control unit.

I would suspect the speedometer to be faulty. An intermittent speedo signal would probably trigger the engine ECU to set a fault code and turn on the check engine light.
Hoygaard is offline  
Status: - Update
Posts: n/a
Re: Speedometer/odometer problem

My speedo flickered from 60-80 and 80-100 today, only for a few seconds and was fine after.

Any ideas?

Status: -
Join Date: Feb 2007
Posts: 2

Member car:

156 1.8TS Volece

Re: Speedometer/odometer problem

I have been experiancing the same problem with my 156, recently had the ABS sensor replaced but warning light will not go out.
bm38 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

problem , speedometer or odometer

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome