Alfa Romeo 147 selespeed problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 27-10-13 Thread Starter
Status: -
Join Date: Oct 2013
Location: Denmark
County: Vestjælland
Posts: 1
Alfa Romeo 147 selespeed problem

I own a alfa romeo 147 2,0 selespeed from 2001.

And now i have a problem with the gears.

Wien i open the door, the pump is running, i get in and start the car, then i can put it in Reverse, but not in first gear. I have tried to hold the gear at + up for about 5secs. Then it SAS, selespeed problem and go in Neutral in City mode. Then i opened the hood, and checked the Oil for the selespeed gears, it looks fine. And suddenly i could get it in 1, and drive perfectly.. The i hold still with Engineering off for about 15 mins, then same problem. Then i went out and opened for the oil again, waited 5 secs closed again, and the no problem? What is wrong here, it happens alot.. And sometimes when i drive, i jump to Neutral, and 1 is flashing, and it jumps from 2 to 4 too, then back then N then back.. Someone know the issue here?

Thanks for lisenting, i hope someone Can help
Parbst147 is offline  
Sponsored Links
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026

Its very hard to diagnose selespeed problems without connecting to AlfaDiag or similar, however common issues are pressure problems caused by a tired accumulator, corrosion on the multiplug (sits down by the thermostat) or a pump not making enough pressure or a faulty position sensor.

The first I would do is clean up the multiplug with contact cleaner, as it is cheap and easy to do. There after it is computer time I think.

Hope this helps
purple145 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , gear , problem , romeo , selespeed , selespeed failure

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome