156 1.9Jtd_2005. Interior Heating Problems, (Possible Solution) - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 27-10-13 Thread Starter
Status: -
Join Date: Apr 2012
Location: United Kingdom
County: Gloucestershire
Posts: 5
156 1.9Jtd_2005. Interior Heating Problems, (Possible Solution)

Afternoon. Just wanted to share for the possible benefit of other Alfa owners out there suffering the same problem.
I have been experiencing issues with the interior temp control unit. The original unit on the car would change temperature and the displays of its own accord, usually switching to 'Hi' temp setting. A 2nd hand replacement worked fine for 3 months until it recently started just running hot whatever temp the display said. Anyway, today I took the control panel out, removed the temperature sensor from the heater control panel; its a round black plug in cigar shaped unit about 2 1/2" long and noticed where it sat in the panel's facia the recess was caked up with dust as was the end of the sensor unit. Clean out both areas carefully taking care not to damage wire, (temp sensitive / bi-metallic??), in the head of the temp sensor. Put it all back together and it works fine, the air temp through the vents increases/decreases as you rotate the controls accordingly.
I see a few people have reported the same issues with heater controls on this forum and my Alfa Specialist garage says the 156's heater control panel is notoriously problematic. So perhaps once a year from now on I will take out and clean the sensor to keep it clear of any clogging dust build up, after all its only a 20-30min job all in, (once you know where all the screws are and the sequence of dismantling the gearstick console and ashtray and stereo removal to actually access and remove the heater control panel)!
Cheers, Phil.
AlfaPhil33 is offline  
Sponsored Links
Status: Newbie
Join Date: Nov 2013
Location: Banksia Park, S A
County: Australia
Posts: 8

Hi mate.
Can you give me or redirect me to the instructions for the sequence of dissemble/reassemble mentioned?
stuvw is offline  
Status: Alfa fanatic
AO Member
j300sjl's Avatar
Join Date: May 2009
Location: United Kingdom
County: -
Posts: 401
Yes mine does this too - so i need to know how to take it apart as well please - anyone?
j300sjl is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 19jtd2005 , heating , interior , problems , solution

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome