156 SW rear seat armrest broken. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
156 SW rear seat armrest broken.

I actually moved the rear seat armrest yesterday for the first time in over two years of ownership. It promptly came away in my hands.

I'm assuming some bits are missing or broken. There is a grey plastic clip on one side, but not the other.

Don't suppose anyone has one kicking about or knows of a fix for this? It isn't vital, but now slightly annoying that I've noticed it.

[color=gray]Sent from AutoGuide.com Free App[/color]
Sponsored Links
Status: GTA facelift + engine rebuild. In progress
Club Member
Membro Premio
Joss's Avatar
Club Member Number: 1014
Join Date: Sep 2005
Location: United Kingdom
County: Dorset
Posts: 18,898
Images: 14
Not sure if it GTA specific over a normal armrest mate
Joss is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , armrest , broken , rear , seat

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome