Coolant leak Alfa156 Jts - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 25-10-13 Thread Starter
Status: -
AO Member
Join Date: Dec 2010
Location: United Kingdom
County: Tyne and Wear
Posts: 100

Member car:

156 2.0 JTS 2004

Coolant leak Alfa156 Jts

I've recently replaced my radiator and now I'm still losing coolant . It appears that it is leaking from the plastic pipe that runs along the front of the engine. I can be driving up until 1/4 way up on the temp gauge and find steam coming up from under the bonnet and other times it has reached over half way and no steam. I'm a bit stumped as to the inconsistency. I'm considering taking the plastic pipe off to check the source of the leak but a bit worried I may make it worse.

Does anyone know how difficult it is to remove or had a similar problem.
smithp77 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alfa156 , coolant , jts , leak

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome