Oil light..... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 23-05-06 Thread Starter
Status: -
chrisd_b's Avatar
Join Date: Sep 2005
Location: Beds
Posts: 7,679
Images: 5
Cry Like A Baby Oil light.....

Driving along and all of a sudden a wizzing noise, followed by something like something disengaging.....then Oil light...

I know I had plenty of oil..

But on investigating it seems that the top crank is not getting any oil, and sounded like a diesel tractor....possible pump problems or pick up?

So now I wait and see what Lisles of Hitchin say is wrong....but at the moment they are not sure what has happened...any ideas much appreciated..!!!

chrisd_b is offline  
Sponsored Links
Status: -
AO Platinum Member
Gary Slegg's Avatar
Join Date: Feb 2006
Location: North Wales
Posts: 16,710
Re: Oil light.....

I guess one of the oil channels must have got blocked?
Gary Slegg is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

light , oil

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome